Can't SSH from command line

I'm running RubyMine 2021.3 in a WSL2 environment.

My ultimate goal is to run a `bundle exe cap production deploy` which deploys my app to a remote server. Unfortunately, it just hangs forever. 

If I attempt to ssh-in to the server from the command line, the same kind of lag happens, and I can't help but wonder if the two issues are related.

I can start an SSH session just fine using the configuration I built in the Tools menu, but I have to begin the deployment process locally, and Capistrano follows a process to ssh in using other credentials.

What more info can I provide to help find a solution?

 

11 comments
Comment actions Permalink

Hello,

Could you please specify in which case manual connection via SSH hangs and in which works fine for you.

0
Comment actions Permalink

Hey, thanks for responding!

I can ssh via the terminal using Powershell and Command Prompt. 

0
Comment actions Permalink

Could you please provide the exact steps for reproduce? Or record a screencast showing the problem. 

0
Comment actions Permalink

I'm just using `ssh <username>@<server address>` and then I expect to see a response from the server requesting my password.

With Powershell and Command Prompt, I receive the response as expected. With WSL, ssh just hangs until it times out.

0
Comment actions Permalink

I'm not sure this matters or not, but new terminals initiate with the heading "local." My assumption is that, by following the instructions for using WSL that this is a WSL shell. I could very well be wrong.

0
Comment actions Permalink

Do you run this ssh command in the built-in Terminal? Does it work in the external one?

0
Comment actions Permalink

Sorry for getting back to you so late with a response! And thank you again for your continued assistance.

So I'm not sure what the difference between the "external" terminal and the "internal" terminal is. I really only thought there was the integrated terminal.

 

0
Comment actions Permalink

Additionally, I just noticed yesterday that using the same ssh options I've created in SSH configurations do not actually work from the new beta "Remote development" section.

0
Comment actions Permalink

I was wondering whether you're running it via Tools | Start SSH session and if so it'd be interesting to know how it goes if you start ssh via the Terminal (without IDE). As for the Remote Development, please submit a separate issue on our tracker for that https://youtrack.jetbrains.com/issues/CWM

0
Comment actions Permalink

Ugh. It appears attempt to ssh from WSL in an external terminal doesn't work either. Looks like this isn't a JetBrains issue, ah?

0
Comment actions Permalink

In this case it might be indeed not an IDE's problem.

0

Please sign in to leave a comment.