Missing quick documentation on mouse hover

When I hover my mouse cursor over any function call I'm not getting any popup about function details.

When I press CTRL+Q I get such details but I want it on mouse hover.

The option "Show on mouse move" from this window context options menu doesn't work because clicking on it doesn't make any effect at all except closing the menu.

1
16 comments

Hi there,

1) Please show the menu that use see on that Quick Documentation popup (need to see what options are enabled).

BTW: Clicking there works fine for me: the window/popup stays active on screen after the click. I'm on Windows 10, latest PhpStorm 2021.3.1

2) Will it work if you enable this option via the Settings screen?

 

1

I don't have this checkbox :/



0

Weird...

1) What OS is that? Please use "About" and use Copy button there (or Ctrl+C shortcut) and paste the full info here (you can remove licensing info if so desired)

2) Show your current full Quick Documentation popup (need to see how it looks). Use it on a some PHP standard function.

3) "Settings/Preferences | Plugins" -- please filter and show here all custom (not bundled by default) plugins.

0

1) Windows 10 Pro 19042.1415

2)

3) I cannot filter not bundled plugins.

0

I reinstalled PHPStorm removing all settings and I still don't have quick doc option in settings.
Very nice.

0

2)

The popup content looks similar to mine here, so it's does not seem to be caused by some plugin that I had in mind.

Can you use keyboard to trigger that option? Any difference?

 

3. I cannot filter not bundled plugins.

 

I reinstalled PHPStorm removing all settings and I still don't have quick doc option in settings.

How did you remove all the setting? In Uninstaller?

If you are using a default plugin to Sync your setting with JB account then they may survive that (not using it, so it's just a thought).

I suggest you try "File | Manage IDE Settings | Restore Default Settings" -- it should make a backup of them before resetting so you can restore it back.

 

I also suggest you to check your idea.log file for possible exceptions -- it may give some hints ("Help | Show Log in Explorer").

The info from About screen (the one on Ctrl+C) may also give some hints (custom/hidden options used should be listed there). Maybe it's one of them...

0

I did everything and nothing changed.

Gonna try it on different device and different OS.

0

Could you please run Help > Collect Logs and Diagnostic Data and share the resulting archive? You can do that via e.g. https://uploads.jetbrains.com/

0

Standalone works on newest Ubuntu.

Gonna try it on Win 10 but other PC.


I'll go back to this topic after 2 weeks.

0

I have the same problem. I can hit View -> Quick documentation or ^J to open the quick doc. Selecting the "show on mouse move" in the 3 dot menu does nothing (is always disabled again). The code editing menu has the same options as the screenshot of  Swierczekraf

I'm using the latest intelij ultimate on OSX (issue was also present in 2021.3.2). My coworkers have the same setup but not this issue.

1

Similar issue: https://intellij-support.jetbrains.com/hc/en-us/community/posts/4998885022866-Tooltip-on-mouseover-does-not-showing-v-2021-3-

Related tickets:

Please check the comments there for some possible workarounds. It could be that you have a screen reader / some accessibility functionality enabled at the OS level, the IDE detects this and disables certain IDE options...

0

Thanks for help. Changing the value of HKEY_CURRENT_USER\Control Panel\Accessibility\Blind Access to 0 and restarting OS solved the problem.

1

I also did some voice control toggling in OSX and this fixed the problem.

3

Yes, changing the value of HKEY_CURRENT_USER\Control Panel\Accessibility\Blind Access solved same problem for me too, thank you!

0

Hi, I had the same issue, the "Show quick documentation on hover" option was not visible and the toggle of "Show on Mouse Move" was not working either on my pycharm.

It turns out IntelliJ's screen reader option was the culprit. As stated in the document when this option is enabled, it disables tooltips and some other staff. IntelliJ shows some prompt whether you want to enable screen reader on the first launch after installation. And after that there is no option to disable it in the normal config.

https://www.jetbrains.com/help/idea/accessibility.html#enable_screen_reader

I managed to turn it off by editing the config directly. Setting `<option name="supportScreenReaders" value="false" />` in the config file "/Users/{username}/Library/Application Support/JetBrains/PyCharmCE2022.2/options/ide.general.xml". (the filepath varies on your environment)

Edit: there were the toggle in the settings "Settings / Preferences | Appearance & Behavior | Appearance -> Support screen readers"

16

Hi, I had the same issue, the "Show quick documentation on hover" option was not visible and the toggle of "Show on Mouse Move" was not working either on my pycharm.

It turns out IntelliJ's screen reader option was the culprit. As stated in the document when this option is enabled, it disables tooltips and some other staff. IntelliJ shows some prompt whether you want to enable screen reader on the first launch after installation. And after that there is no option to disable it in the normal config.

https://www.jetbrains.com/help/idea/accessibility.html#enable_screen_reader

I managed to turn it off by editing the config directly. Setting `<option name="supportScreenReaders" value="false" />` in the config file "/Users/{username}/Library/Application Support/JetBrains/PyCharmCE2022.2/options/ide.general.xml". (the filepath varies on your environment)

Edit: there were the toggle in the settings "Settings / Preferences | Appearance & Behavior | Appearance -> Support screen readers"

 

This fixed it for me as well - I edited the file directly, cannot comment on UI toggle. Unsure if it's set to true by default, or if I managed to misclick something (I do not use any screenreader). 

Machine:
MBP 16" 2021 (M1 Pro) - Ventura 13.4.1

PyCharm:
PyCharm 2023.1.4 (Professional Edition) / Build #PY-231.9225.15  / 17.0.7+10-b829.16 aarch64 /JB OpenJDK 64

Interpreter:
Python 3.11 (inside .venv associated with pyenv & poetry)

Thanks Giga!

0

Please sign in to leave a comment.