PHPStorm indexing forever and getting hanged after installing the latest version.

I upgraded my PHPStorm to the latest version few days back. Now it's randomly getting hanged after indexing for unlimited time. The indexing never finished, and this behavour is not random, it's always indexing without reaching the finishing line ever. I also tried invalidating cache and restarting PHPStorm several times as other posts suggested. Nothing worked.


My Machine: 

Processor Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz 2.50 GHz
Installed RAM 16.0 GB (15.4 GB usable)
System type 64-bit operating system, x64-based processor

My OS: 

Edition Windows 10 Pro
OS build 19043.1415

PHPStorm Version:

PhpStorm 2021.3.1
Build #PS-213.6461.83, built on December 29, 2021
Licensed to BusyLamp GmbH / Ahmed Al Imran
Subscription is active until September 30, 2022.
Runtime version: 11.0.13+7-b1751.21 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 10 10.0
GC: G1 Young Generation, G1 Old Generation
Memory: 1972M
Cores: 4

Non-Bundled Plugins:
com.intellij.php.codeigniter3 (0.6.0)
ru.adelf.idea.dotenv (2021.3.0.213)



Is there any chance that you have a WSL-based project? If this is the case, please try a workaround from this ticket:


Vasiliy Yur

Spot on!

Yes, it is a WSL-based project. The solution mentioned in this ticket fixed my issue.

Thanks a lot. 


Please sign in to leave a comment.