Keymapping mac os / Linux

I have been working with Jetbrains IDE's for years now, but I was always using Linux. Now I changed jobs and got a macbook. And oh-my, almost all shortkeys are different.

Is there a way to use the keymappings from linux on the mac? (in preferences I see stuff for eclipse, emacs, sublime, and visual studio, but nothing for Linux users...

for instance, I use ctrl-q a lot, to check info on a function, but that didn't work, and so I automatically try cmd-q because, that's how it goes for copy pasting right :-) so now I have to reopen phpStorm all the time I do that, because cmd-q ofcourse closes the application... Also other things like ctrl-insert, ctrl-p etc. non of it works anymore... it feels like I am trying out a completely new IDE... WAAAA HELP ME! going nuts here. I want my linux back :-( 

And it also doesn't help that my own PC is a Linux computer, so when I do something on there I have to switch back again

I hope someone has a good solution for this...

 

 

5 comments
Comment actions Permalink

Hi there,

You can download Linux based keymaps.

Or even import yours from your Linux (it's just a XML file).

https://www.jetbrains.com/help/phpstorm/sharing-your-ide-settings.html#import-export-settings

0
Comment actions Permalink

Thanks,

I tried downloading GNOME and KDE, but with both even backspace and delete are not working anymore, and still ctrl-shift-f and cmd-shift-f  do nothing.

1
Comment actions Permalink

Not a Mac user so cannot help with testing it more than this. I thought it would work (at least for most of the keys) as it worked when a few years ago I suggested the same for Linux <--> Windows setup...

Right now I may only suggest to manually change the shortcuts in the Mac Keymap to the working combinations.

Perhaps someone from JetBrains Support Team can point to a better solution later.

0
Comment actions Permalink

Windows and Linux keymaps are identical, so give IntelliJ IDEA Classic a try.

0
Comment actions Permalink

When using GNOME, some of the `IntelliJ IDEA Classic` key mappings clash with GNOME desktop bindings. So IntelliJ helpfully provides a GNOME keymap.

The GNOME keymap works for me on macOS (once I realised that I need to restart the IDE after changing the keymap). Ctrl-shift-f, backspace, delete work for me. Every other keystroke I've tried works (except for Ctrl + Insert [but I wasn't familiar with that one]. Ctrl + C works!). Did you restart your IDE after changing the keymap?

0

Please sign in to leave a comment.