How to stop PHPStorm from opening files in already opened tab

As a title said, I would like to stop PHPStorm from opening files in already opened tab and instead to open them in a new tab. Any setting for that? Thanks!

6 comments
Comment actions Permalink

Please check if Closing Policy has a value of more than 1 in "Settings/Preferences | Editor | General | Editor Tabs":

0
Comment actions Permalink

I have a default value set of "10".

0
Comment actions Permalink

@Rajster Miha

Can  you make some small screencast (video) that would illustrate how it actually works for you / the context matters here. If not a video then perhaps a bunch of screenshots with arrows/explanations.

Does it happen when you try to open files from the Project View panel ... or a code navigation inside the Editor?

Is it some Distraction Fee/Zen/Full screen mode active? Check/show "Main Menu | View | Appearance"

Right now:

1) Maybe it's one of these options:

2) If it's code navigation then perhaps you have this one enabled?

You need to better describe what you have got there.

0
Comment actions Permalink

@Rajster Miha

Thanks for the video.

From what I see that editor tab uses italic font for the file name, which suggests that it's a Preview Tab.

Disable that option under the Cog icon and try again (see my 1st screenshot above).

1
Comment actions Permalink

That's it! Thank you very much! It was driving me insane.

0

Please sign in to leave a comment.