I can't execute the toolbox in Linux

I have lost 3 days with this that is why I open the question, I am kind of desperate.

I want to use Scalene wich only works in Linux and Mac. My plan was installing Ubuntu for Windows, which I did, then Pycharm, and finally Scalene. The problem is I followed this instructions:

https://www.jetbrains.com/help/idea/installation-guide.html#toolbox

"Install the Toolbox App

Download the tarball .tar.gz from the Toolbox App web page.

Extract the tarball to a directory that supports file execution.

For example, if the downloaded version is 1.17.7391, you can extract it to the recommended /opt directory using the following command:

sudo tar -xzf jetbrains-toolbox-1.17.7391.tar.gz -C /opt

Execute the jetbrains-toolbox binary from the extracted directory to run the Toolbox App and select which product and version you want to install. After you run the Toolbox App for the first time, it will automatically add the Toolbox App icon to the main menu."

But I can't execute the binary from the extracted directory. I found it in this direction:

C:\Users\my_name\AppData\Local\Packages\CanonicalGroupLimited.Ubuntu20.04onWindows_79rhkp1fndgsc\LocalState\rootfs\opt\jetbrains-toolbox-1.22.10970

And when I enter the shell I get to "LocalState" but when I try "cd rootfs" I get:

"-bash: cd: rootfs: Permission denied"

I tried to close, then click on ubuntu's icon "run as administrator" but get the same error.

Does anybody know how can I execute the jetbrain toolbox?

I tried this also:

https://github.com/nagygergo/jetbrains-toolbox-install

But I can't find any icon.

Thanks!!!!!

3 comments
Comment actions Permalink

My plan was installing Ubuntu for Windows,

You mean WSL, right? 

C:\Users\my_name\AppData\Local\Packages\CanonicalGroupLimited.Ubuntu20.04onWindows_79rhkp1fndgsc\LocalState\rootfs\opt\jetbrains-toolbox-1.22.10970

That's not how you supposed to access the WSL file system. Instead, you should run the WSL shell (simply typing "wsl" or "ubuntu" in the terminal should do), and then you should be able to `cd /opt/jetbrains-toolbox-1.22.10970` or where it was extracted. Note that you should have X11 forwarding configured, or have WSL GUI support enabled to be able to use GUI applications from inside WSL.

Have you considered installing PyCharm for Windows and using the WSL interpreter instead?

0
Comment actions Permalink

First of all, thank you so much for your reply.

So all I want is a package called "Scalene" which only works in Linux and Mac. I prefer to avoid Linux if possible because, as you may have noticed, I have no practice with it. But the question is, if I use Pycharm in Windows and select the WSL interpreter, Will Scalene work 100%?

If the answer is not I have another question. I tried what you said, typed "WSL" on Windows and got the penguin icon, then typed what you said and entered the proper folder. Then to execute the tool I tried ./ (googled and found to execute a file you have to use that syntax) and got the error you see in this image:

I am reading your tutorial to "Run Linux GUI apps on the Windows Subsystem for Linux" but I have Windows 10 so I will have to update the computer tomorrow.

edit:

I see the WSL interpreter is a feature for Pycharm Pro, Is that correct?

Regards!

 

 

0
Comment actions Permalink

But the question is, if I use Pycharm in Windows and select the WSL interpreter, Will Scalene work 100%?

WSL v2 is a Linux virtualization, so anything that runs on Linux should run on WSL as well.

You likely already have WSL v2, but if not, I would recommend upgrading your image from v1 to v2:

- https://docs.microsoft.com/en-us/windows/wsl/install#check-which-version-of-wsl-you-are-running

- https://docs.microsoft.com/en-us/windows/wsl/install#upgrade-version-from-wsl-1-to-wsl-2

 

Yes, WSL support is part of PyCharm Professional, and this is what I would recommend. 

You can install PyCharm Community directly inside WSL and forward the UI to your desktop using X11 forwarding or WSL GUI support (as mentioned in my previous reply), but I would say it's for advanced users.

0

Please sign in to leave a comment.