Unable to add Python Interpreter in PyCharm

I've been trying to add a Python Interpreter to PyCharm, but there appears to be a bug - there is no option to add an Interpreter within the PyCharm settings (see below screenshot).

Some guides point to the bottom bar containing an option to switch Interpreter - but that is not an option for me (see below screenshot). What can I do to set the Python Interpreter?

1
16 comments

It could be a known issue https://youtrack.jetbrains.com/issue/PY-48492, please try the workaround from there. Let me know if it doesn't help.

1

Thanks Andrey, that was the issue.

Copying and pasting that workaround here:

  1. Close your project in PyCharm
  2. Create a backup of your .idea/ folder
  3. Remove .idea/ folder
  4. Re-open your project

Your project will be reinitialized. You could then copy some of the settings files from your backup to your new .idea/ folder.

Thanks again!

2

This is not working for me. Its a complete nightmare. I jsut want to set an interpreter. Any other things i can do ?

0

Hi ! 

Same issue and the workaround doesn't work for me neither

I even tried to delete and reclone my project. 

Impossible to set an interpreter

0
Please check if the issue still happens with default settings.

To restore default settings, you can use **File | Manage IDE settings | Restore Default Settings...**. Your current settings will be backed up, so you can revert to them later if needed (to do this, just import settings from the backed up folder).
3

Hello ! 

I just tried it and it worked for me.

Thanks a lot and have a nice day

 

2

A bug that forces you to abandon pycharm. Should use another IDE.

2

Hello aleks.farrier,

Could you please try workarounds from earlier posts? 

If they are not helpful, please create an issue on YouTrack and attach idea.log(Help | Show Logs in...) to the thread.

0
  • THis is also happening with the latest PyCharm. There are so many bugs with PyCharm now, and this is the `nail in the coffin` for me. 
  • Debugger using modules just will not work – No one cares to fix it properly 
  • Now the Python Interpreter cannot be loaded, I keep pointing it to a PATH where the venv exists locally ,and it will not pick it up, this is highly frustrating and absolutely a nightmare for productivity. We are a company and cannot deal with this above garbage of a IDE that you guys are shipping now . 

    I am moving to NeoVim permanently and will just set up stuff manually, because using recent Pycharm has been an absolute nightmare of installs, reinstalls, cleaning Python, deleting repositories, etc .. and the debug goes on and on …

 

2

Same issue here, even with the very latest PyCharm. Neither of the solutions suggested work, and I cannot add an interpreter. Switching to VSCode until this is fixed. 

0

I faced the same problem on MacOS and was able to fix it by removing all the dots from the project folder name.

0

I just encountered same issue, but after I rename my ./venv → ./venv311, then it works. I think pycharm kept the venv name in cache somewhere, so it thought the venv already invalid and it won't add it again.

Maybe we should name the venv with hash….

1

I  have paid $99 for pycharm pro, but the issue is still here, bad experience, switch to vscode. Fuck you pycharm 

1

OK, this worked. I was able to use a new Poetry interpreter. Before, I could select the new interpreter and pycharm just would not take it. Basically, the new selection was ignored.---------------

Please check if the issue still happens with default settings.

To restore default settings, you can use **File | Manage IDE settings | Restore Default Settings...**. Your current settings will be backed up, so you can revert to them later if needed (to do this, just import settings from the backed up folder).

0

I love PyCharm, but the frustration with trying to set a venv is very, very real.  For me, the Restore Default Settings worked (eg, after installing a new Python version).

I hope the PyCharm team takes this frustration to heart.  It consumes hours to days.

I'd suggest some way of detecting that the settings are broken (for me, a tip was SDK name is use, but heaven only knows where that was), and provide an “override - use this venv!", or a button/message about the Restore Default Settings.  My main point, I think it's urgent you do something.

0
Hello there, 
There might be several reasons for the inability to add Python interpreters in PyCharm. If you encounter this issue, please get in touch with support with Help | Contact Support or create an issue on YouTrack so we can investigate the problem and provide a solution.
0

Please sign in to leave a comment.