"Waiting for connection..." when trying to debug a Python project in a Docker via SSH

I have a server where Docker is installed and I can reach it via ssh. All ports (should) be reachable, I can login via ssh, use SMB etc. I created a new python project, setup the deployment and can run it successfully. However, trying to debug it ends in "Waiting for connection..."

 

I've checked on the server that the Container is running and it seems the ports are forwared

And here are my project settings

Note I'm using python:latest as in your Docker example. All connections test suceed. Instead of using .ssh/config I also tried to configure it directly and with port 22 with no success.

I also tried to connect to the port on the server (see screenshot above) with telnet, it works.

What else could I check?

1 comment
Comment actions Permalink

Looks like you need the tunnel from target to host, for example (in this case) by running:

ssh -L 53942:localhost:53942 10.64.87.255

on the host running PyCharm.

0

Please sign in to leave a comment.