How to disable java type renderer?

Answered

I added a custom java type renderer to show `long` as something different, but now *all* longs are rendered in that format, always!

Even when I right-click and select Render As→Primitive, it only renders that single variable as a number, and only temporary. When I restart the debugger, all longs, including that one, are rendered using using my renderer again.

When I delete my renderer, it's all fine again, but I don't want to delete my renderer as I want to juggle with some variables using my renderer for a while.

Preferably I want all longs to be rendered as number and change the renderer of some appointed variables on demand (I don't mind doing this every time I restart the debugger as it's only two variables I want to render differently.)

2 comments
Comment actions Permalink

I thought I had just answered my own question, by adding watches, but the next time I start the debugger, the imports are lost.

0
Comment actions Permalink

Hello,

You may disable custom renderer and use "Render as" for those two variables.

0

Please sign in to leave a comment.