Hex color preview in gutter shows only 4 colors

Hello, 

I don't know this is a bug or feature request.

I'm using code like:

$colors-ui: (
'grey': ('lightest': #eeeeee, 'light': #d2d2d2, 'normal': #c1c1c1, 'dark': #999, 'darkest': #3a3a3a),
'green': ('lightest': #d7e8c4, 'light': #bde093, 'normal': #6cc04a, 'dark': #28a834, 'darkest': #00833e),
'blue': ('lightest': #cce5f4, 'light': #b6c2e9, 'normal': #62b3e5, 'dark': #0b3486, 'darkest': #071d49),
'red': ('lightest': #f7eae4, 'light': #f0b3ca, 'normal': #e45385, 'dark': #dd3a76, 'darkest': #f9423a),
'orange': ('lightest': #ffe1c6, 'light': #ffbe85, 'normal': #f78d2d, 'dark': #e57a18, 'darkest': #d75f00),
);

But in this case gutter shows only 4 colors:

Perhaps there is a way to increase size of gutter? Or there is limit for color preview count?

 

details:

RubyMine 2021.3.2
Build #RM-213.6777.43, built on January 26, 2022
Subscription is active until September 21, 2022.
For educational use only.
Runtime version: 11.0.13+7-b1751.25 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 12.2.1
GC: G1 Young Generation, G1 Old Generation
Memory: 2048M
Cores: 8
Registry:
    ide.images.show.chessboard=true

Non-Bundled Plugins:
    com.github.copilot (1.1.12.524)
    izhangzhihao.rainbow.brackets (6.21)
    ru.adelf.idea.dotenv (2022.1)

2 comments
Comment actions Permalink

This is not configurable unfortunately

I can suggest to either wrap the lines to reduce the number of keys shown per a line or disable color preview in the gutter in Settings | Editor | General | Gutter Icons and use the preview as background (Settings | Editor | General | Appearance, Show CSS Color Preview as background) instead:

 

0

Please sign in to leave a comment.