Mouse move CPU load 90%, even with Power mode enabled!

Hi, I believe this affects all intellij softwares..at least I tried with php storm and pycharm.

Moving the mouse around, even with power mode enabled, spikes the cpu to 90% and I have a pretty good pc (4800U).

Older versions (2019) didn't have this obvious issue, my laptop battery is hugely impacted by this.

How can I solve this issue? 

I want my ide to just do nothing as I move the mouse around. No cpu should be impacted.

Version Build #PS-213.6777.58, built on January 31, 2022 (but It doesnt matter...does the same with older versions too)

Power safe mode should REALLY save my battery.

4 comments
Comment actions Permalink

Please open Help | Diagnostic Tools | Activity Monitor and let me know what you see there when you move the mouse pointer.

0
Comment actions Permalink

voilà, moving the mouse (no real differences with power safe mode)

I'm currently running win 11

PHPSTORM

Build #PS-213.6777.58, built on January 31, 2022

Runtime version: 11.0.13+7-b1751.25 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.

%CPU  Subsystem

 79,3  <Process total CPU usage>
 47,5  <infrastructure: AWT-Windows>
 15,5  <infrastructure: UI thread>
  2,7  <JIT compiler>
  2,3  <unidentified: UI thread>
  1,9  <Garbage collection>
  1,5  <Activity Monitor>
  1,5  ui.tabs.impl (in com.intellij)

 

PYCHARM

Build #PC-213.6777.50, built on January 27, 2022Runtime version: 11.0.13+7-b1751.25 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.

 %CPU  Subsystem

 85,1  <Process total CPU usage>
 39,4  <infrastructure: AWT-Windows>
 22,7  <JIT compiler>
 13,9  <infrastructure: UI thread>
  4,6  <unidentified: UI thread>
  3,1  ui.tabs.impl (in com.intellij)
  1,5  <Activity Monitor>
  0,7  jdk.internal.logger

0
Comment actions Permalink

well, after digging online, lowering the polling rate of the mouse can mitigate this issue. I had 1000hz polling rate in my logitech control panel. Lowering it to 125hz I get this:

 %CPU  Subsystem

 20,9  <Process total CPU usage>
 14,7  <infrastructure: AWT-Windows>
  2,3  <infrastructure: UI thread>
  0,7  vfs.newvfs.impl (in com.intellij.openapi)
  0,7  <unidentified: UI thread>
  0,7  editor.impl.view (in com.intellij.openapi)
  0,7  <Activity Monitor>
  0,7  application (in com.intellij.openapi)

 

So this magical "infrastructure: AWT-Windows" passed from 45% CPU to 15%, it's a pretty significant change.

I still think it really should not behave like this (other softwares are not even close to this bad performance shown in Pycharm)..but ok.

0
Comment actions Permalink

Thank you for the update! There was no chance I could figure it out.
This issue seems to have been reported already: https://youtrack.jetbrains.com/issue/IDEA-182544
I've added a link to the forum thread in a comment there.

0

Please sign in to leave a comment.