Code With Me Remote Users Keeps Freezing

Hello, I'm trying to host a "Code With Me" session in a relatively small HelloWorld codebase. However, my remote session users' JetBrains Client keeps freezing. We have tried increasing their IntelliJ heap size in JetBrains Toolbox. They tried restarting their computer ( which seemed to stave it off for a while but they still eventually froze within another 30 minutes. We stopped using the calling feature from within IntelliJ in case it's causing issues.

Does anyone know anything that can help fix this? 

Any more details I can help to add context?


I just tried it with me as the remote user and it froze. Seems to be correlated with when we are typing at the same time, but not 100% sure.


Another thing is the voice call continues to work even when the client is frozen until even that eventually freezes and stops, so not sure if that's related to anything.


Hello, I found that downgrading from IntelliJ 2021.3.2 to 2021.2.4 solved this issue for us.


Exact versions are: 

Freezes constantly: 213.6777.52

Works just fine: 212.5712.43


According to Code With Me plug-in, the latest version bundled with intelliJ version 2021.3.2 is actually an EAP. I find it odd that y'all would bundle what basically is a beta version with the stable intellij release.


We have exactly the same problem in our team! The remote users will freeze after some short time and they even have to kill the java task in order to restart IntelliJ. The problem exists at least since fall 2021 when we first tried Code with Me.

We all use IntelliJ IDEA Ultimate on Ubuntu 20. However, instead of the full IntelliJ I also tried with the thin client once, but it also froze. We do not use the voice or video features, because we have an external video conference running all the time.

This paid feature (for unlimited time and more collaborators) is simply not usable for us like it is now and we often have to switch to VS Code's Liveshare instead. Please fix it! Thank you very much!


Christian Stricker What version of IntelliJ is the host using? Apparently that matters. I had to downgrade to 2021.2.4 instead of 2021.3.2 for it to work. It doesn't matter about the clients, but the host of the session absolutely needs to be on a lower version of InltelliJ. 

For me, what I did is I have both the latest version of IntelliJ and 2021.2.4 installed using Jetbrains Toolbox and use 2021.2.4 for when I want to pair and that works for us, fortunately.

The clients also don't use IntelliJ to connect to the session, but the command line copy/paste the link provides. Not sure if that matters, I don't think it does, but fwiw that's fixed it for us for now. Hopefully newer versions of IntelliJ solve this painful problem.


Same problem here. It's very random. Some days, it can go for an hour before freezing. Other days like today, it may only last a minute before freezing. Latest versions of IntelliJ etc.


GoldFlsh Thanks for the comment concerning the version: We are using snap (see to always automatically use the latest version. A manual downgrade probably would not be a realistic option due to our internal security policies. Moreover, the problem also appeared already during last November, when we probably were still using a 2021.2 version, but I am not totally sure about it any more.


Christian Stricker

>We are using snap (see to always automatically use the latest version

Including EAPs? recent changes go to EAP builds.

For the users who faced this problem:

Please collect logs from both sides when the problem reappears and submit them as issues at

with visibility "jetbrains-team":

For a host:
For a guest:

Better the whole directory, including threadDumps archives if they exist. Thank you.


Concerning the version: We use the latest/stable channel, so no EAPs, because we use on productive deployment.


I created a YouTrack issue with the same logs here:

Please feel free to add logs and experiences as additional comments there! Let's hope that this bug can be fixed soon!


Please sign in to leave a comment.