Project panel doesn't show the folders and files are looking as external (?)

The files are looking as ignored files, and not all files and folders are listed!

Tried to delete the ./idea and reopen it but didn't work.

The repo was cloned through the New -> Project from Version Control 

WebStorm 2021.3.2

Comment actions Permalink

Can be fixed, if you Quit the Webstorm completely (no other projects open), delete the ./idea, and then open again the project.

Comment actions Permalink

your .idea files are likely broken, the .iml file and/or modules.xml are either missing or corrupted. Deleting and re-creating .idea folder should help:

  • close the project
  • remove it from Recent projects list
  • shut down the IDE
  • delete the .idea folder
  • restart, open the project root folder with File > Open
Comment actions Permalink

I have another problem now, with the same project. It doesn't recognize that the project has a git repo. There is no Git option anywhere in the IDE! Other projects are working well. Of course, the git is there ".git" and git commands are working from bash, confirmed.

I have tried your steps twice but didn't work.

How to make it work?

Comment actions Permalink

Any suggestion on how to enforce Webstorm to see that the project is a repo?

Comment actions Permalink

in Settings | Version Control | Directory Mappings, try choosing GIT as your VCS

Comment actions Permalink

I had the same issue.  I fixed by using the /File/Repair IDE


Please sign in to leave a comment.