Project panel doesn't show the folders and files are looking as external (?)

The files are looking as ignored files, and not all files and folders are listed!

Tried to delete the ./idea and reopen it but didn't work.

The repo was cloned through the New -> Project from Version Control 

WebStorm 2021.3.2


Can be fixed, if you Quit the Webstorm completely (no other projects open), delete the ./idea, and then open again the project.


your .idea files are likely broken, the .iml file and/or modules.xml are either missing or corrupted. Deleting and re-creating .idea folder should help:

  • close the project
  • remove it from Recent projects list
  • shut down the IDE
  • delete the .idea folder
  • restart, open the project root folder with File > Open

I have another problem now, with the same project. It doesn't recognize that the project has a git repo. There is no Git option anywhere in the IDE! Other projects are working well. Of course, the git is there ".git" and git commands are working from bash, confirmed.

I have tried your steps twice but didn't work.

How to make it work?


Any suggestion on how to enforce Webstorm to see that the project is a repo?


in Settings | Version Control | Directory Mappings, try choosing GIT as your VCS


I had the same issue.  I fixed by using the /File/Repair IDE


Fuck, when jetbrains shit stop to do it???


I have this almost every upgrade of IDEA. 

deleting .idea folder indeed fixes the problem, but you lose then all datasorces, runconfigurations, etc.
Instead of deleting, just rename it, so you can copy the folders 'dataSources', 'runcConfigurations', 'shelf', etc.

(going through all steps of the File / Repair IDE did not solve the issue)


I had the same issue. 

It's because Intellij don't have the access to document, desktop, etc folder.. 

see. :

I don't know how autorize Intellij but when I try in an other folder at the root of my mac it's workink well


Please sign in to leave a comment.