"HTTP/1.1 header parser received no bytes" when running with "runIde" (sandbox)

Answered

Hi everybody, my custom IntelliJ plugin shall fire HTTP requests against an intranet server. The code works nicely in a test and also if I install the plugin in my "real" IntelliJ instance - but when running in the IDE sandbox, I keep getting "HTTP/1.1 header parser received no bytes" when trying to login (sending an HTTP POST request).

Is networking somehow restricted in the sandbox? I have already tried to turn off the firewall, no change. We are also behind a corporate proxy but that shouldn't matter, as it is an internal IP. I also thought about TLS problems (we are using a self signed certificate), but problems with the certificates usually result in a different exception (PKIX path building failed [...] unable to find valid certification path to requested target).

Do you have any ideas? Best regards!

2 comments
Comment actions Permalink

Are the two instances the exact same IDE version, and both using the same Java Runtime? Also check system/VM parameters for any differences. What library do you use to issue HTTP requests?

0
Comment actions Permalink

Hello and thanks for the quick reply!

While collecting the info for my answer, I found out that indeed proxy settings were the issue (the proxy was used although it shouldn't have been). Problem solved!

Your request pointed me to the right direction. I didn't understand that the "sandbox" IDE has completely independent network settings from the host IDE and is not really a sandbox (in the sense of isolation).

https://plugins.jetbrains.com/docs/intellij/ide-development-instance.html could document that more clearly. It could also point out that the the "sandbox IDE" version can be configured via

intellij {
version = '2021.3.2'
}

So thanks again and have a nice weekend!

0

Please sign in to leave a comment.