How can I configure the Ruby SDK?

Hello, I'm in trouble.

My editor shows "No Ruby interpreter configured for the project".

But when I clicked "Configure" link, it looks being set as ruby-2.6.5. 

How can I solve this problem?

 

my environment is:

 

3 comments
Comment actions Permalink

Hello,

Could you please attach a screenshot from the Modules tab as well?

0
Comment actions Permalink

Olga Kuvardina

Hi. 

Finally, I removed `.idea` folder and opened the project again, and the Ruby was correctly configured. Thank you.

2
Comment actions Permalink

That worked for me ^^

I also had to update misc.xml to set the ruby version correctly as it picked the wrong one in the list breaking the project from importing and then I had to run 'Repair IDE' when I right clicked on the project.

 

0

Please sign in to leave a comment.