PhpStorm keeps crashing on Project-Change since 2021.3.3

Hi,

since the last update to 2021.3.3, PhpStorm keeps crashing randomly. This mostly happens when I try to change projects, however, it has also happened during coding. The error logs contain different types of causes:

  • EXCEPTION_GUARD_PAGE (0x80000001)
  • EXCEPTION_ACCESS_VIOLATION (0xc0000005)
  • Internal Error: Fatal error initializing "*.DaemonCodeAnalyzer"

I have not changed a thing since the last update, everything stayed the same. I tried to completely delete PhpStorm and reinstall it. Also made sure, that all system drivers are up-to-date. Still the same behaviour.

I'm running a Windows 10 machine with WSL2.

3 comments
Comment actions Permalink

Just happened again, during coding, not project change:

#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000005daf9d0, pid=19352, tid=21764
#
# JRE version: OpenJDK Runtime Environment JBR-11.0.14.1.1-1751.46-jcef (11.0.14.1+1) (build 11.0.14.1+1-b1751.46)
# Java VM: OpenJDK 64-Bit Server VM JBR-11.0.14.1.1-1751.46-jcef (11.0.14.1+1-b1751.46, mixed mode, tiered, compressed oops, g1 gc, windows-amd64)
# Problematic frame:
# v  ~StubRoutines::jlong_disjoint_arraycopy

---------------  S U M M A R Y ------------

Command Line: exit -Xms128m -Xmx750m -XX:ReservedCodeCacheSize=512m -XX:+IgnoreUnrecognizedVMOptions -XX:+UseG1GC -XX:SoftRefLRUPolicyMSPerMB=50 -XX:CICompilerCount=2 -XX:+HeapDumpOnOutOfMemoryError -XX:-OmitStackTraceInFastThrow -ea -Dsun.io.useCanonCaches=false -Djdk.http.auth.tunneling.disabledSchemes="" -Djdk.attach.allowAttachSelf=true -Djdk.module.illegalAccess.silent=true -Dkotlinx.coroutines.debug=off -Xmx2048m -Djb.vmOptionsFile=C:\Users\user\AppData\Roaming\JetBrains\PhpStorm2021.3\phpstorm64.exe.vmoptions -Djava.system.class.loader=com.intellij.util.lang.PathClassLoader -Didea.vendor.name=JetBrains -Didea.paths.selector=PhpStorm2021.3 -Didea.platform.prefix=PhpStorm -Dsplash=true -Dide.native.launcher=true -XX:ErrorFile=C:\Users\user\java_error_in_phpstorm64_%p.log -XX:HeapDumpPath=C:\Users\user\java_error_in_phpstorm64.hprof 

Host: AMD Ryzen 5 4500U with Radeon Graphics         , 6 cores, 39G,  Windows 10 , 64 bit Build 19041 (10.0.19041.1566)
Time: Wed Mar 23 12:37:34 2022 W. Europe Standard Time elapsed time: 9652.807901 seconds (0d 2h 40m 52s)

---------------  T H R E A D  ---------------

Current thread (0x000000015e250800):  JavaThread "JobScheduler FJ pool 1/5" daemon [_thread_in_Java, id=21764, stack(0x0000000078db0000,0x0000000078eb0000)]

Stack: [0x0000000078db0000,0x0000000078eb0000],  sp=0x0000000078eac790,  free space=1009k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C  0x0000000005daf9d0


siginfo: EXCEPTION_ACCESS_VIOLATION (0xc0000005), reading address 0x000000016231a000
0
Comment actions Permalink

Could you please submit your logs (Help | Collect Logs and Diagnostic Data) in a bug report on our tracker?
https://youtrack.jetbrains.com/newIssue?project=WI

The community forum is not the most convenient place to discuss this kind of issue. Thank you!

0
Comment actions Permalink

It just happened again during project change. Same DaemonCodeAnalyzer problem as posted before.

I will try to post a issue as soon as possible.

// I already created a ticket via the PhpStorm Error-Log modal-window.

// It just happened again. PhpStorm is currently somewhat unusable for me.

// See https://youtrack.jetbrains.com/issue/WI-65860

0

Please sign in to leave a comment.