Webstorm 2021.3.3 can no longer debug javascript server side

If I run a debug,  on  a vue project it no longer works.

"serve": "vue-cli-service serve --host",

10:25 AM    Error running 'default server dev npm serve': Language Language: JavaScript doesn't participate in view provider com.intellij.psi.SingleRootFileViewProvider{vFile=LightVirtualFile: /fragment.js, content=VirtualFileContent{size=0}, eventSystemEnabled=true}: [Language: TEXT]


Happens on multiple projects, that worked prior.


Works in 2021.1.3

WebStorm 2021.2.4
Build #WS-212.5712.44, built on December 21, 2021

Also fails in EAP. 2022.1 Build #WS-221.5080.67


Please share a screenshot of the error


Does the issue persist after caches invalidation?

BTW, does the issue only occur when running NPM script in debugger? Do you try to debug the vue-cli-service?


Same issue happening on IntelliJ IDEA 2022.1 Ultimate (any typescript project)

Build #IU-221.5080.210, built on April 12, 2022

To reproduce on a typescript project : `node -r ts-node/register/transpile-only --inspect ./src/index.ts`

Try to attach the debugger and you will have the same error.


can't reproduce with provided steps

Is the issue specific to the certain project? Does the issue persist after caches invalidation? Can it be reproduced with a new project? Also, please could you share the idea.log (Help > Show Log in ...)?


Invalidated caches. Still and issue
new project, that has issues:

Just submitted a bug so I could attach the log:



Happens in multiple projects:

  • two vue-cli
    "serve": "vue-cli-service serve --host",
  • one gatsby/netlify: 
    "start": "netlify dev",



Thanks for submitting youtrack ticket, I've replied there


Uninstall WebStorm - > Remove /Users/****/Library/Application Support/JetBrains/WebStorm****.*  folder  -> Re-install WebStorm

Solve the issue


@all: if you face the

Language Language: JavaScript doesn't participate in view provider com.intellij.psi.SingleRootFileViewProvider{vFile=LightVirtualFile

issue when starting the debugger, make sure that you have *.js extension assigned to the JavaScript file type in Settings | Editor | File Types


The solution was to use File>Manage IDE Settings > Restore Default Settings
and a repair IDE was in the list of items, executed.

I made my configurations 'Store as Project File' and saved them outside the .idea folder


Please sign in to leave a comment.