PyCharm won't open a specific project

Answered

I recently started having an issue with PyCharm not opening one of my repositories. It doesn't seem to matter what method I use to open it, clone it, or anything else like that. It simply opens up to what appears to be a blank page (when trying to tab into the project, it will not display on the screen). Interestingly, files will not open when part of this project, but if copy pasted elsewhere they are fine until they are reassigned to the project. I tried deleting the .idea folder and the fresh one created when trying to open the project does not fix the issue. I'm not given any diagnostic info or a failure message when I've tried any of these approaches, so I'm at a total loss for what is actually wrong. I am using PyCharm 2021.3.2.

6 comments
Comment actions Permalink

Hi, could you please provide a screenshot of the issue and Logs from **Help | Collect Logs and Diagnostic Data** after reproducing the issue?

You can use uploading service at https://uploads.jetbrains.com/ , and provide upload ID in your reply. 

0
Comment actions Permalink

Hello Andrey,

I was actually able to get in for the first time since this started just now! I opened it in an already opened window instead of creating a new window. I've attached logs of both the successful and failed attempts to open. I'd like to get this working, but now that I have a workaround it's not a huge deal to me.

 

Upload id: 2022_04_12_HfU5nwxXi1d8mAKN (files: pycharm-logs-new-window.zip, pycharm-logs-same-window.zip)

 

 

 

 

0
Comment actions Permalink

Seems that something is wrong with the interpreter

com.jetbrains.python.sdk.InvalidSdkException: Failed to determine Python's sys.path value:

Could you please provide the `python -V` and `python -c "import sys; print(sys.path)"` outputs from the interpreter used in the problematic project?

0
Comment actions Permalink

I'm having exactly the same problem with the variation that PyCharm won't open a window at all, it simply puts an icon in the task bar. If I hover over it it shows a blank window but nothing I can do will open that window. I can shutdown PyCharm by clicking the X that is shown when hovering over the taskbar icon.

 It worked fine last time I opened the project and I cannot think of anything that has changed on my PC recently.

I have a dozen other projects that follow the same pattern and the ones I've tries all open correctly except the one I need to work in - of course. Each of these projects each have their own virtual environment.

I'm using 

PyCharm 2022.1.2 (Professional Edition)
Build #PY-221.5787.24, built on May 31, 2022
Runtime version: 11.0.15+10-b2043.56 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 10 10.0
GC: G1 Young Generation, G1 Old Generation
Memory: 1006M
Cores: 12
Registry:
    debugger.watches.in.variables=false

Non-Bundled Plugins:
    net.seesharpsoft.intellij.plugins.csv (2.18.2)
    NodeJS (221.5787.15)

I was using an earlier version but upgraded in case that was the problem. It made no difference.

After I attempt to open the broken project, the log file reports a few SEVERE warnings:

2022-06-07 11:05:18,235 [  37691] SEVERE - #c.i.o.w.i.WindowInfoImpl - Frame bounds are invalid: java.awt.Rectangle[x=-1043,y=-21,width=1015,height=902]
2022-06-07 11:05:18,238 [  37694] SEVERE - #c.i.o.w.i.WindowInfoImpl - PyCharm 2022.1.2  Build #PY-221.5787.24
2022-06-07 11:05:18,238 [  37694] SEVERE - #c.i.o.w.i.WindowInfoImpl - JDK: 11.0.15; VM: OpenJDK 64-Bit Server VM; Vendor: JetBrains s.r.o.
2022-06-07 11:05:18,239 [  37695] SEVERE - #c.i.o.w.i.WindowInfoImpl - OS: Windows 10

But no errors.

I've tried deleting the .idea directory and recreating the project but that didn't help. I recerated the virtual environment but that made no difference either. Trying to open the project while another project that works is open still only adds an icon to the task bar for the broken project.

`python -V` and `python -c "import sys; print(sys.path)" just point to the virtual environment, when it is activated, or the system python when it isn't. Unclear which one would be used when recreating the project. In both instances the code is running Python 3.9.9.

0
Comment actions Permalink

The work around you mention fixed the issue. And after applying it successive opening aren't affected.

Thanks.

0

Please sign in to leave a comment.