Extra blank lines in editor


The java editor is displaying extra space between methods and enum items.  In the examples below there are no blank lines in the files but the java editor is displaying the files with extra space. You can see this with the extra space between the line numbers.

This seems to have started with the latest 2022.1 update.

What setting do I need to change to get rid of these extra spaces?

Comment actions Permalink

Hi Brian,

This must be a recent regression: https://youtrack.jetbrains.com/issue/IDEA-290051

The fix should be available in the next bugfix release for version 2022.1 due end of April.

Possible workarounds for now are:

  • File | Settings | Editor | Inlay Hints > uncheck Code Vision if you don't use it
  • If you do, then it should be enough to uncheck specifically the Code Author part of the code vision inlay hints
  • Alternatively, you can add editor.codeVision.new=false in Help | Edit Custom Properties, and restart the IDE

Sorry for the inconvenience.

Comment actions Permalink

Thanks for your help.  I don't use Code Vision and turned it off and the extra lines are gone.

Comment actions Permalink

I'm so glad I found this. Thank you, Arina.

Comment actions Permalink

Hi. I have disabled Code Vision as described above, but just wanted you to know that this issue is still present in IntelliJ IDEA 2022.2.1

Comment actions Permalink

The issue should be fixed. If you see it in the current version, please file a new bug.


Please sign in to leave a comment.