Datagrip can't turn off keep alive queries on Snowflake

Answered

I've carefully gone through my settings and turned off keep alive queries anywhere I can.  For some reason, every time I run any query in my console I can look in my Snowflake query history and see that three separate "Select 1" queries were run before my actual query, and then one last "Select 1" query was run after my actual query.  How can I turn off all these redundant "Select 1" queries?  They're driving me crazy.

It also happens when I first open datagrip so I assume it has something to do with connecting each query console or something.

I'm using DataGrip 2022.1.1

3 comments
Comment actions Permalink

After much troubleshooting, I traced this down to a problem with the JDBC driver for Snowflake.  When I use the JDBC 3.13.10 driver I have the problem, but if I downgrade to JDBC 3.13.5 it works fine.

1
Avatar
Yuriy Vinogradov
Comment actions Permalink

Yes it's hardcoded in their driver.

1

Please sign in to leave a comment.