Windows 11, cygwin, rsync upload not working

Hi, I am using PhpStorm 2022.1 on Windows 11 with latest cygwin installed. I am trying to get rsync up-/download working with the following settings:

But I keep getting this error:

Upload to server.tld failed. Failed to transfer folder 'c:Folder\Folder'. Unknown message with code "Rsync failed with exit code: 12".

Rsync works on the remote server (testet via local Ubuntu VM).

Any hints are much appreciated! :)

 

3 comments
Comment actions Permalink

What is yours authentication type in a corresponding PhpStorm SSH configuration?

How exactly do you authenticate when you run rsync manually? Please check these two tickets that discuss the same problem: https://youtrack.jetbrains.com/issue/WI-64208 & https://youtrack.jetbrains.com/issue/WI-63553

0
Comment actions Permalink

Thx for your reply! Yes, I read those threads but didn't help.
I use pageant as SSH-key agent. I tried the new Windows ssh-agent which works manually to. I tried sharing the ssh-agent keys in cygwin on startup which works manually on the cygwin shell but ont in phpstorm.

I know came to another solution which fixes some other issues for me, too: I use wsl2 with xwindow and installed the Linux version of phpstorm. 

Everything works fine now. I just have to add my keys to the agent twice :)

0
Comment actions Permalink

Thanks for sharing the workaround!

0

Please sign in to leave a comment.