Load variables from file

Greetings everyone!
Since last update I have no luck loading environment variables from file. 2 weeks ago I still was able to specify an .sh script with a lot of <VAR>=<value> lines that set up my environment for every executable binary. But now, going to "Edit configurations..."->"Environment variables:"->"Load variables from file:" and choosing appropriate .sh-script seems to do nothing at all. If I run this binary from terminal after executing my .sh everything works just fine. Is there some changes in loading-environment-variables logic? Or have I messed something? Could anyone give a clue?
CLion Build #CL-221.5080.224, built on April 13, 2022

OS: Ubuntu 18.04

2 comments
Comment actions Permalink

I've solved my problem only by downgrading to 2021.3.4 (Build #CL-213.7172.20, built on March 14, 2022). It works now.  For those who faced this or simmilar problem:

clion@release:~$ snap remove clion
clion@release:~$ snap install clion --channel=2021.3/stable --classic

Looking froward to new stable releases.

0
Comment actions Permalink

Hello!

  1. Do you happen to use ROS?
  2. Do you use the environment script in your toolchain `File | Settings | Build, Execution, Deployment | Toolchains`  (see https://www.jetbrains.com/help/clion/quick-tutorial-on-configuring-clion-on-windows.html#env-scripts)?
0

Please sign in to leave a comment.