Not able to update intellij plugin to support latest version of intellij

Answered

I am trying to update my intellij plugin to 2022.1. But I got some NoClassDefFound error for some class names SystemInfoRt.

So After searching few blogs, I found that I have to update my grade intellij plugin and I updated it from 0.7.2 to 1.5.2 as suggested.

Now I am getting some dependencies errors as shown below. Please help

4 comments
Comment actions Permalink

Please share link to your sources or provide Gradle build file and gradle.properties contents.

0
Comment actions Permalink

Below is my build.gradle file and I don't have gradle.properties file

plugins {
id 'java'
id 'org.jetbrains.intellij' version '1.5.3'
}

group 'org.aj'
version '3.3.6-SNAPSHOT'

sourceSets.main.java.srcDirs 'src/main/gen'

repositories {
mavenCentral()
}

dependencies {
testImplementation 'org.junit.jupiter:junit-jupiter-api:5.8.2'
testRuntimeOnly 'org.junit.jupiter:junit-jupiter-engine:5.8.2'
}

// See https://github.com/JetBrains/gradle-intellij-plugin/
intellij {
version '2022.1'
plugins = ['com.intellij.java']
}

publishPlugin {
token = System.getenv("plugintoken")
}

test {
useJUnitPlatform()
}
0
Comment actions Permalink

The line `version '2022.1` must be `version = '2022.1'`

1
Comment actions Permalink

Thank you for the info Yann. It works.

0

Please sign in to leave a comment.