Autocompletion stopped working when the project is working with docker-compose

Current version:

PhpStorm 2022.1.1

Build #PS-221.5591.58, built on May 12, 2022

I haven't been able to solve this problem for three days. I have more than 30 projects in my locale and autocomplete works fine for all of them except for those projects that are configured via docker.

Can this somehow affect the work of autocomplete?

 

 

Please help me, I tried all the options I found, but not one did not help.

My OS - Ubuntu 20.04.4 LTS

12 comments
Comment actions Permalink

Generally, it does not matter what type of PHP CLI interpreter is configured, it should not affect autocompletion.

Not sure if I understood it correctly, is the codebase located in Docker container and then mounted to host/project, right? 

0
Comment actions Permalink

Yes, the codebase located in Docker container and then mounted to host/project,  and code autocompletion doesn't work at all for PHP, JS, Vue, HTML and CSS. But it works very well for all projects that are not located in Docker containers.

It's been more than 10 days I can't fix it.

0
Comment actions Permalink

I reinstalled Phpstorm several times, deleted all the folders associated with Phpstorm from my OS. I even deleted the whole project and reinstalled it, but nothing helps. Ctrl +Space and Ctrl +Shift +Space do not show anything.

0
Comment actions Permalink

With Ctrl +Space and Ctrl +Shift +Space

0
Comment actions Permalink

And all this happened after the last upgrade. I've always had projects with Dockers, and everything worked fine.

0
Comment actions Permalink

Please try to disable Tailwind CSS plugin at Settings (Preferences on macOS) | Plugins & check if that helps. 

If not - run Help > Collect Logs and Diagnostic Data and share the resulting archive using https://uploads.jetbrains.com/

0
Comment actions Permalink

Thank you very very much. Removing the Tailwind CSS plugin helped me.

0
Comment actions Permalink

Finally my phpstorm is back. The best IDE in the world.

0
Comment actions Permalink

Thanks for the update. That's a bug and we're working on it in https://youtrack.jetbrains.com/issue/WEB-54433 - please vote for it in order to get notified about its updates & increase its priority.

0
Comment actions Permalink

Thank you too.
Done.

0

Please sign in to leave a comment.