3 comments
Comment actions Permalink

As far as I can see, a tutorial looks a bit outdated. For new versions of a JDBC driver, you should use jdbc:databricks:// instead of jdbc:spark://.

Please let me know if it helps.

As alternative, you can download 2.6.22 version of the driver from https://databricks.com/spark/jdbc-drivers-archive to follow-up this tutorial.

1
Comment actions Permalink

Thanks Daniil, I tried your suggestions to change the string to databricks and downloaded to previous versions of the driver and still couldn't connect.  I tried every combination of authentication and tried the Databricks SQL endpoint along with cluster connection, still no success.  I'm not sure what else I could try....something tells me it has something to do with DataGrip confusing this driver for Azure SQL Database.

0
Comment actions Permalink

Please upload the IDE logs (Help | Collect Logs and Diagnostic Data) to https://uploads.jetbrains.com/ and provide its ID.

0

Please sign in to leave a comment.