Error in Flask profile. Follow
I am working on a Flask app in PyCharm. The app was developed originally in VS Code and the developer has specific instructions for setting up venv manually, but since I am using PyCharm I want to use the Flask configuration.
When I set up the configuration profile for Flask, It works, but I have a red "X" on the profile name and there is an error at the bottom of the configuration screen that says "Warning: Flask >= 1.0 is required"
I checked the installed Flask version and it is 2.0.3
Also, it seems to run the app fine...
So what's the "Warning" about??
Please sign in to leave a comment.
Do you see the package among the installed ones in File | Settings | Project | Python Interpreter?
If so, try File | Invalidate Caches...
There was nothing there. I set the interpreter to Python 3.9 and it filled in with all of the dependencies, including Flask, and the red Xs and warning went away. :-)
In my case, the problem had arisen from two active interpreters simultaneously. I removed one of them from the list of interpreters, and the issue was resolved.