How do I get IntelliJ IDEA to display directories?

Answered

Javascript I've been trying out IntelliJ IDEA for JavaScript editing, and I like it so far, but I'm having a small problem with a new project. I can't seem to be able to get IDEA to display the directories in the project directory in the Project view. Even if I manually add a directory, it refuses to display it. I think this probably has something to do with the fact that it tries to apply Java conventions, but when I imported an old Eclipse project, it showed all directories just fine. Do I have to use Eclipse to create projects and import in IDEA to get the directories visible, or is there some other trick? I am using IDEA version 8.1.3, and the code is just a plain bunch of HTML and JavaScript files, not in any kind of a Java environment.visit official site

0
5 comments

In the top left corner, you have several option to display your project : 

You can choice Project Files to see all directories and files but if you don't see your directories in the Project view, there is issues wtih the index of your project made by IntelliJ.... sometimes it happens...
You just have to close IntelliJ and delete in your project directory, the .idea folder. Then repoen IntelliJ.

0

Hello,

Please attach screenshot with your project tree in IDE and from file manager.

1

Still an annoying problem.

Where is /usr/lib/jvm?

0

Solution: this is a flatpak version of IntelliJ so path has to be prefixed with /var/run/host for intellij to see it

0

Jon Martin Solaas

 Solution: this is a flatpak version of IntelliJ so path has to be prefixed with /var/run/host for intellij to see it

Could you please advise what was the solution in your case? Where have you provided the mentioned prefix? Thanks!

0

Please sign in to leave a comment.