SQL Server Code completion does not include schema name

Answered

Brand new to Datagrip:

If I have a Microsoft SQL Server connection, and I have ATable in schema ASchema, as I start writing the query "select * from", I get a code-completion prompt to select ATable (good), but if I hit TAB to select it, Datagrip does not include the schema name, so I end up with "select * from ATable".  In order for the query to run successfully, it needs to be "select * from ASchema.ATable".

Is there a setting somewhere to enable this behavior?  Without it, code completion for SQL server just isn't very useful I'm afraid.

1 comment
Comment actions Permalink

See the settings under Preferences | Editor | General | Code Completion

0

Please sign in to leave a comment.