Help with the Datagrip Bigquery connection

Answered

Hello everyone,

I have a question regarding the authentication via the google user account when connecting datagrip with google Bigquery. Once I set up the Data source and added the authentication via a google user account (as shown in the jetbrains documentation), I have to add the authentication code every time doing an operation in data grip. Can this state be avoided so that I have to enter the access token just on the first time of the new connection (initially)?

9 comments
Comment actions Permalink

Hello,

Please open up data source properties, go to Options tab and enable Single session mode.

Does it help?

0
Comment actions Permalink

Hey Daniil,

yes, I already did but it doesn't work. I still have to reenter the access token.

kind regards

0
Comment actions Permalink

what exactly do you want to know? And can you tell me where I can find the specific Bigquery connection in my data grip?

 

0
Comment actions Permalink

A screenshot of your Services tool window (View | Tool Windows | Services) would be helpful.

You can find details about your connection by clicking on the data source name and selecting Data Source Properties button.

0
Comment actions Permalink

like this?

 

0
Comment actions Permalink

alright, this is the screenshot from my service window tool

 

0
Comment actions Permalink

Could you please share a screenshot with BigQuery execution and the expanded tree of Google BigQuery_test? I see an example of PostgreSQL on your screenshot, which is not so relevant in our case.

0

Please sign in to leave a comment.