How to disable json schema in json scratch files?

When I create a json scratch file and paste in some arbitrary json I'm working with, its all highlighted red with "missing" and "not allowed" properties because its applying a schema to it. This is a scratch file so it should have no schema applied. How can I disable this?

I looked on this page

which said this:

If your configuration file has a custom name or you are working with a scratch file, click No JSON schema on the Status bar and select the required schema from the list or click New Schema Mapping to open the JSON Schema Mappings page and configure a new custom schema.

1. I do not see a "No JSON schema" option anywhere

2. These instructions don't seem to make sense as the next thing it says is "select the required schema" (I don't want a schema)!




this is not currently possible - you can choose a schema different from auto-detected one, but there is no way to set it to 'none'; please vote for to be notified on any progress with this ticket

For now, I can only suggest disabling the JSON and JSON5 | Compliance with JSON schema inspection in Settings | Editor | Inspections to stop the IDE complaints


Disabling the inspection is good enough for me I think, thanks!


Please sign in to leave a comment.