UI Frozen several minutes before opening the first project

Hello,

since a few days, when I launch PhpStorm, the UI is frozen for a few minutes before opening a project. After that, I can open and close projects normally and fast. It's very annoying...

I have uploaded the logs, if someone can have a look, thanx !

(Upload ID: 2022_07_05_25EyZWdXbBzWqKk3Nyii1p)

0
14 comments

Updated PhpStorm to the latest version, same problem...

 

PhpStorm 2022.1.3
Build #PS-221.5921.28, built on June 22, 2022
Licensed to (...)

Runtime version: 11.0.15+10-b2043.56 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 12.4
GC: G1 Young Generation, G1 Old Generation
Memory: 4096M
Cores: 12
Registry:
    run.processes.with.pty=TRUE
    search.everywhere.settings=true
    ide.balloon.shadow.size=0

Non-Bundled Plugins:
    ua.in.dej.myEmmet (1.2.5)
    top.walterInKitchen.gitDiffShort (1.1.14)
    some.awesome (1.14)
    net.seesharpsoft.intellij.plugins.file-preview (1.6.4)
    net.seesharpsoft.intellij.plugins.csv (2.18.2)
    monokai-pro (1.8.1)
    krasa.IdeaIconPack (1.12)
    krasa.CpuUsageIndicator (1.14)
    com.intellij.ideolog (203.0.30.0)
    com.github.googee.laravelgenerator (3.1.3)
    bundled-phpstorm-help (221.5921.28)
    String Manipulation (9.5.0)
    HighlightBracketPair (1.3.4)
    zielu.gittoolbox (212.9.0)
    mobi.hsz.idea.gitignore (4.4.0)
    com.intellij.plugins.html.instantEditing (221.5921.12)
    de.espend.idea.php.annotation (8.2.2)
    com.kalessil.phpStorm.phpInspectionsEA (4.0.7.1)
    de.espend.idea.laravel (0.15.4)
    izhangzhihao.rainbow.brackets (6.25)
    dev.ekvedaras.laravelquery (3.2.1)
    com.mallowigi (64.0.0)
    ru.adelf.idea.dotenv (2022.1)

0

I tried to deactivate all downloaded plugins, it doesn't help...

Still 4 or 5 minutes before the IDE becomes usable.

0

Please try disabling the EditorConfig bundled plugin, does it help?

1

Yes, thanx ! IDE opened and ready in less than 10 seconds...

Is it related to the plugin or to my projects ?

0

Here's an example of .editorconfig in one of my projects :

# EditorConfig is awesome: https://EditorConfig.org

# top-most EditorConfig file
root = true

[*]
indent_style = tab
indent_size = 4
end_of_line = lf
charset = utf-8
trim_trailing_whitespace = true
insert_final_newline = true

[*.{yml,yaml,md}]
indent_style = space
indent_size = 2

[*.{xml,xml.dist,json}]
indent_style = space
indent_size = 4
0

Thank you for the update.

Seems to be, the plugin is the one to blame here.

Sadly, I was not able to reproduce the issue on my side with your .editorconfig file. Looks like, the file alone is not enough for issue to appear.

Not sure if you have already tried it but would it be possible to run the Invalidate Caches operation and check if the issue is still reproducible with the enabled plugin?

0

Thanx for your answer.
I tried that, enabled Editorconfig plugin, invalidated caches, restarted, and same problem, UI frozen again on "Loading components", with PhpStorm process at 200% CPU in MacOs Activity Monitor.

Too bad, this plugin is usefull but I'll work without it until it's eventually fixed.

Am I the only one, and is there anything I can provide you to help understand the problem ?

0

Thank you for your reply.

Sad to hear that cache invalidation did not help. You are not alone with this problem but it is quite a rare occasion and we have not managed to find a root cause or catch the pattern yet. I understand how it may sound like but would it be possible to share the affected project privately, so I could check if this issue is reproducible and has something to do with a project itself and/or its code base?

0

Yes, I can give you access to a 88MB tar archive of a project without anything private, it's a clean install of the CMS I'm working on, the freeze happens on this one too.

What's the limit on https://uploads.jetbrains.com/ ? If 88MB is too big, I can upload this tar somewhere and send you the link by email with https://www.wesendit.com/ for example.

0

In fact, I don't know the exact limit for the JetBrains uploads but 88mb should not be the problem, so you may freely use it.

0

So, here it is : 2022_07_07_28KyLx7BgyG6SbN6quHpwo

Let me know if you need more information.

0

Thanks for sharing these.

I was not able to reproduce the issue while playing around with your project (tried opening various files, ran a full inspection check, etc).
However, I have managed to find a YouTrack report with quite similar behaviour and thread dumps:
https://youtrack.jetbrains.com/issue/IDEA-295036/Very-slow-Reopening-files

According to the ticket details, the issue should be fixed in 2022.2 EAP already. Would it be possible to install it in parallel and check if it is still reproducible there for you?

Just in case:
https://www.jetbrains.com/phpstorm/nextversion/

1

Yes, I can confirm you it's fixed in 2022.2 EAP. That's very good news :)

I installed 2022.2 EAP, launched it, activated the Editorconfig plugin, closed PhpStorm, reopened and my project was here in a few seconds.
I tried several times to close it completely and reopen with other projects : very fast, no problem at all.

Thanx for your support and to the team for the excellent work, I'm very happy to use Jetbrains IDEs for several years now.
(and I have no problem with the prices rising, I'd still pay even if it was more expensive for this excellent daily tool that provides all I need and more)

I'll stay on the stable version for now, but I'm glad to know it will soon be fixed :)

0

Thank you for the confirmation and for your kind words! :)

Hopefully, the issue will not reoccur on a stable release of 2022.2 when it comes. However, if it happens, please feel free to let me know.

By the way, the 2022.2 version is on a Beta phase since today, so a stable release is about to appear quite soon.

0

Please sign in to leave a comment.