Disable code completion for Shell files?

Answered

I'm getting code completion in *.sh files and it's worse than useless; every recommendation is just wrong and gets in the way.

I tried disabling the included "Shell Script" plugin with no changes. I searched and browsed all through preferences and saw nothing about turning code completion off for just one language. 

Is there a way to do this?

I can override the filetype and open it as a plain text file. That works but I lose color coding.

2 comments
Comment actions Permalink

Hi Samuel Neff There is this link on jetbrains for autocompletion which helped me so it will change what bash completion I enter. https://www.jetbrains.com/help/pycharm/auto-completing-code.html#postfix_completion

When it loads the graphic UI did you try these options ? Not sure there is a way for it to identify shell script, but you could probably play around with creating a script that if extension of the file is *.sh then disable completion?

0
Comment actions Permalink

Hi Samuel,

You can't do it per file type/language I'm afraid, but you can temporarily disable showing suggestions while working with .sh files.

To do it quickly, press Shift-Shift, type "show sug" and hit Enter.  

When the settings dialog appears, clear the box that says "Show suggestions as you type":

0

Please sign in to leave a comment.