Error importing module even though it works correctly in IDLE with the same python interpreter version

I'm attempting to import more_itertools module from the python 3.10.2 console in PyCharm 2021.3.3 (Community Edition), but it's giving me a moduleNotFoundError. 

I have already performed the pip install of more_itertools and Pandas (someone said I needed pandas also) from the command prompt on Windows 10.  I have verified that the correct version of pip is installed (22.2) and that it's using the correct version of python.  Also I only have one python interpreter installed.

I tried the same import using python IDLE and the import works, and I can use the functions fine.  python IDLE has the same python interpreter (3.10.2) configured.

Do you have any suggestions?  I'm a newbie just so you know.

2 comments
Comment actions Permalink

Hello, 

 

Do you see the package installed in

[Project Interpreter Settings](https://www.jetbrains.com/help/pycharm/installing-uninstalling-and-upgrading-packages.html#interpreter-settings)? 

Please click + sigh, find more-itertools and install it in the selected interpreter. 

 

Let me know how it goes. 

1
Comment actions Permalink

That fixed it, thank you so much.  

0

Please sign in to leave a comment.