Error tooltips not showing on hover

As you can see in the GIF, there is an error there but when I hover there is no tooltip. It used to work. I can't remember how long it hasn't been working for though.

I have tried disabling all downloaded plugins with no success.

I have the Show quick documentation on hover option enabled. Not sure what else I can do.

I am on 2022.1.4 and the shortcut Ctrl + F1 works and shows the tooltip correctly.

These are my code editing settings. If you want to see any others or want me to export them or any other information for that matter, please let me know.


Please check if you have an "ide.disable.editor.tooltips" option enabled in Registry:

To access the built-it IDE Registry, navigate to "Help > Find action" and just type "Registry" there. 


Thanks for the speedy response. I do not have that value enabled as shown in my screenshot.


I forgot to mention, I am running PhpStorm in WSL and I am using VcXServer to for the graphics.


Thank you for the update. This configuration might be relevant but I was not able to find any similar reports on YouTrack so far.

By the way, is there any chance that you have a debug session running in a background? Also, have you tried changing tooltip delay in both directions?


I don't have any debug sessions running. I don't even have xdebug enabled by default. It's only ran on demand.

Changing the delay down to around 200ms seems to work, thank you. Seems rather odd that a higher delay doesn't work. If I had to guess I'd say it has something to do with x server but I have no idea. I swear it used to work fine though.


Fantastic, thank you for bringing the good news!
Just a random speculative assumption: it might be that VcXsrv intervenes and creates its own delay or has some kind of input refresh rate.

Nonetheless, I am happy to hear that workaround with a lesser delay does the trick. Hopefully, this thread will help someone else as well, thank you for all your updates here.


Thanks for your help!


Please sign in to leave a comment.