Can't install Debugger

After updating Rubimine from 2022.1 (I'm not sure about previous version) to RubyMine 2022.2 (Build #RM-222.3345.111, built on July 25, 2022 MacOS) consistently getting error while running the debugger 

Failed to Install Gems. Following gems were not installed: /Applications/RubyMine.app/Contents/plugins/ruby/rb/gems/ruby-debug-ide-3.0.0.beta.4.gem: Error installing ruby-debug-ide-3.0.0.beta.4.gem: ruby-debug-ide-3.0.0.beta.4 requires Ruby version >= 3.0.0. The current ruby version is 3.0.0.p0. /Applications/RubyMine.app/Contents/plugins/ruby/rb/gems/debase-3.0.0.beta.4.gem: Error installing debase-3.0.0.beta.4.gem: debase-3.0.0.beta.4 requires Ruby version >= 3.0.0. The current ruby version is 3.0.0.p0.

 

3 comments
Comment actions Permalink

solved:

1. rvm remove ruby-3.0.0

2. rvm install 3.0.0 

 

0
Comment actions Permalink

Hello Dmytriy,

glad to know you've solved the problem. We've also a related issue (which you're aware of but it might be useful for other users):

https://youtrack.jetbrains.com/issue/RUBY-30056/Cannot-start-debugger-on-attempt-to-debug-with-Ruby-30-Docker-interpreter

1

Please sign in to leave a comment.