Global Gitignore, because my gitignore files get too long

Answered

I've been trying to figure this out for ages, come across many different articles and posts about it, but nothing seems to work (and are all several years old).

Basically, I have several gitignore files generated by toptal.  Now, I'm pretty certain these aren't accurate, as it does not ignore the whole of the idea folder (and TBH, I think it should be completely ignore).  If the idea folder should be included, please let me know.

Now, since only ".gitignore" works (not "ide.gitignore") and I need to ignore files for the project and IDE, I was wondering what the best practise is.

I don't use PHPStorm exclusively, nor just on 1 machine, and the projects I work with involve several frameworks at the same time.
You can imagine how big 1 gitignore file can get.

Any ideas how to best resolve this?

3 comments
Comment actions Permalink

NextEmployeePortal

o create global gitignore from scratch:

$ cd ~
$ touch .gitignore_global
$ git config --global core.excludesfile ~/.gitignore_global
First line changes directory to C:/Users/User
After that you create an empty file with .gitignore_global extension
And finally setting global ignore to that file.
Then you should open it with some kind of notepad and add the needed ignore rules.

-1
Comment actions Permalink

SEO SPAM link above

0

Please sign in to leave a comment.