Enter and Space keys isn't working


I'm using Mac as part of my work, and my IntelliJ does'nt let me press enter and ignore space. I tried to change keymap, and every solution I found online and nothing worked!


HI Noa,

Do you use any keyboard management software on your Mac? E.g. Karabiner

Does it happen in the code editor only, or in dialogs too? E.g. the search field in Preferences | Plugins


No I don't use Karabiner. I tried to download macOS keymap but it didnt fix the problem :(.

It happens in code editor....


What happens exactly? Do you see the cursor blink or twitch when you press Enter or Space?

Are the keys registered in the 'Find Shortcut' popup?

Does it help if you disable all downloaded plugins and restart the IDE? Preferences | Plugins | ⚙️ | Disable all downloaded plugins


1. When I press Enter this pop-up window opens -

2. In Keymap -

3. Disable all downloaded plugins and restart the IDE didn't help


Please provide the idea.log file (Help | Show Log in...) after reproducing the problem. You can upload it privately to https://uploads.jetbrains.com, and provide the upload id here.


Please sign in to leave a comment.