Single Test / Test-Suite run not picking configuration from template

Using Build #WS-222.3345.108, built on July 22, 2022 on macOS Monterey 12.5:

I am struggling making test runs on click. I have a Jest template on my run configurations :
If I run this conf (which runs all the tests) everything works fine, so the conf is correct

However, If I run a single test, or a single test suite, WebStorm is supposed to create a new run picking the previous template's conf. 
Everything is the same except the 
-Jest options
-Environment variables

Which are empty, so it lacks picking jest custom configuration and also all the env vars.

So I can't run any test by clicking. If I manually add the missing information in the runner created by clicking, everything works again, obviously.

This is being very annoying, I had this feature perfectly working on a previous laptop

I have no idea on how to fix this and I've been looking around some time now.

Any help?
Thanks 

1 comment
Comment actions Permalink

> I have a Jest template on my run configurations :

 

it doesn't look like a template, it is an existing configuration. The options used for new run configurations created when running tests from gutter are based on the corresponding run configuration template. If you need running with specific command line switches/configs, you need modifying the Jest configuration template accordingly

0

Please sign in to leave a comment.