Should I update my plugin for every Intellij version ?

Answered

I have built a gradle based IntelliJ plugin with the below config in build.gradle

intellij {
version = '2022.2'
}
patchPluginXml {
changeNotes = """
Add change notes here.<br>
<em>most HTML tags may be used</em>"""
sinceBuild ='221'
untilBuild ='251'
}


However , the plugin works only for 2022.2 Intellij and it does not work for 2022.3. 

I want my plugin to work for all versions of Intellij.

Could you please help me with the same?

3 comments
Comment actions Permalink

Please don't specify explicit versions which are years away (untilBuild ='251'). You can explicitly set untilBuild to empty/none value to disable restriction with later versions, see https://plugins.jetbrains.com/docs/intellij/gradle-guide.html#patching-the-plugin-configuration-file

0
Comment actions Permalink
intellij {
version = '2022.2'
}
patchPluginXml {
changeNotes = """
Add change notes here.<br>
<em>most HTML tags may be used</em>"""
sinceBuild ='221'
untilBuild=''
}

I changed it empty , but still failing . Is there anything else I need to change ?

Attaching the screenshot of the error 

Current Intellij version : 2022.2

0
Comment actions Permalink

you are building against 222 (2022.2) but setting sinceBuild to 221 (2022.1), but these values should always be equal

please make sure no other part of your Gradle build file interferes with plugin.xml generation, also try Gradle "clean" target to verify

you can check result locally in build/patchedPluginXmlFiles folder

 

0

Please sign in to leave a comment.