Remote development not working when connecting to linux server

Hi, I'm trying to connect PhpStorm to a linux server running WordPress

SSH and SFTP connections work great to this linux server.

When I try to open the remote project, lots of progress bars flash and the gateway starts but eventually everything stalls out and a new PhpStorm project pointing to Remote project folder is never opened.

I can see that:

  1.  the install path and RemoteDev/dist has files etc. installed and seems to look ok
  2.  I pointed the project directory to /public_html; presumably this is ok?  But I don't see an .idea folder (although maybe one is not supposed to be created)

Can someone advise where else I can look to see / diagnose what is wrong and why my Remote Project won't open?

Thanks

 

3 comments
Comment actions Permalink

What IDE version are you using? We would most likely need to inspect IDE logs for that. Please collect them with the help of the article & share with us. You can send them us via Help | Contact Support or upload at https://uploads.jetbrains.com/ & share upload ID.

0
Comment actions Permalink

Hi, I'm on latest 2022.2.  Note that when my Remote IDE choices are presented to me, it's always installing the latest RC (Release Candidate) and not the latest version I'm on and there's no way to choose the identical IDE version.

I've uploaded my logs; share upload id = 2022_08_16_ZsZA7gccVwF2xQkQZRmeAY

I've tried both IntelliJ and PhpStorm and both result in the same behaviour.

Thx

0
Comment actions Permalink

Thanks. Do you have any logs generated at a remote site? The path would look like ~/.cache/JetBrains/RemoteDev-IDE_NAME/PROJECT_PATH/log

 

0

Please sign in to leave a comment.