python files, Pycharm, Raspberry Pi

Just installed PyCharm on Raspberry Pi 4 and am puzzled by the fact that it will not add a .py file. I have created a new project and tried to add a new python file. I get an error, map failed, then unable to save settings, please restart PyCharm.

I assumed it was something to do with file permissions, but can't find a problem there. If I create a new text file, then refactor to .py everything is fine.

Any ideas what is causing this.



The same errors occur if I try to add a python package.


facing same error have reinstalled Raspbian, that didn't helped.    

still looking for a solution





Raspberry Pi hardware is not sufficient for the PyCharm which is a heavy Java desktop application. It is still possible to install custom JDK which works on  Raspberry Pi but we cannot guarantee a stable work. 


Instead, I suggest considering the "Deployment" feature, which allows synchronisation of code between servers. You can edit your code on the local machine and run/debug on the remote Raspberry Pi.

To find out more please see






Please sign in to leave a comment.