Cannot start PyCharm

I just downloaded PyCharm on my virtual machine, my operating system is debian 11 i386. After unzipping the file, I moved it to the opt folder with the name pycharm and when I ran it via sh, I got the following error:

No JRE found. Please make sure $PYCHARM JDK, $JDK_HOME, or $JAVA_HOME point to valid JRE installation.

The commands i did were:

- mkdir pycharm && tar -xvf pycharm-community-*.tar.gz -C pycharm --strip-components 1

- sudo mv pycharm /opt/

- sh /opt/pycharm/bin/pycharm.sh

P.S: I am new doing this kind of thing so I would like you to explain the answer in a way that a beginner would understand it.

Thanks a lot!!! :)

 

 

3 comments
Comment actions Permalink

Hi,

PyCharm uses a bundled Java runtime located in <installation_directory>/jbr -- do you have this directory?

Please check if you have any of the listed environment variables ($PYCHARM_JDK, $JDK_HOME, or $JAVA_HOME) and unset them. Then PyCharm should find the correct jbr automatically.

0
Comment actions Permalink

Hi Andrey Resler,

Yes, i have jbr directory on my installation directory, inside it there are other folders like: bin, conf, include, legal and lib and a .txt called release. I guess that the environent variables are on this last one .txt. Inside it there are a lot of modules but not what we mentioned. 
Trying other solution, I used the command env and printenv but no one of this variables were there.

Anyways i found a solution right here:

https://stackoverflow.com/questions/69005100/error-cannot-install-pycharm-no-jre-found

By doing the next command

sudo apt-get install openjdk-11-jdk

Now PyCharm is running and seems to work correctly but anyway I would like to know how to do what you told me.

0
Comment actions Permalink

Well, I guess it's running with the OpenJDK now. I would recommend switching to the bundled JBR though. More information about how to do that: https://intellij-support.jetbrains.com/hc/en-us/articles/206544879-Selecting-the-JDK-version-the-IDE-will-run-under 

0

Please sign in to leave a comment.