Vagrant VM - pydev debugger: warning: trying to add breakpoint to file that does not exist (random /tmp dir) [SOLVED]

Suddenly debug started having issue in my project. For all the breakpoints I add, it will output the following:

pydev debugger: warning: trying to add breakpoint to file that does not exist: /tmp/goxDO5MEgb/valid/path/from/ (will have no effect)

The script runs fine. I've tried invalidating caches, making a duplicate of the remote Vagrant VM, removing all the breakpoints and re-adding, and checking path mappings to make sure the only on in there is the single Project Root item. I turned on PYCHARM_DEBUG, and all I get of substance is the call to the debugger to add the breakpoint, using the /tmp/..... path. It creates a random dir in /tmp, which is owned by vagrant user, but it never copies the file.

One thing I considered is I am on Windows where I've always been on Linux and I know Windows VirtualBox shares have symlink issues, but /tmp is not a shared folder. It's as if PyCharm never copies (or symlinks) the path in /tmp back to the project file. After execution, the directory made is just empty.

I don't know what is normal on a Vagrant VM Interpreter if it always copies the files to this /tmp dir for breakpoints. I'm inclined to think it is so you can still edit and save the file in the editor and it does not overwrite that file.



Issue is a bug in 2022.2.1 , covered by PY-53567. Solution is to downgrade to 2021.3.3 until issue is resolved. As of right now, and build #PY-223.4884.74 it is still broken.


Cdanderson thank you for posting the ticket number.

I am also experiencing this. I'm on windows 10 and I just tried upgrading virtualbox and vagrant to the latest versions and removed and recreated my remote interpreter in PyCharm with no change.


Experiencing the same issue with PyCharm 2023.1.3 and Ubuntu 22.04. Vagrant box is also running Ubuntu 22.04. Is there a solution aside from downgrading to 2021.3.3?



It seems like a known issue.

The fix should be available in the upcoming EAP version. Please keep an eye on the EAP releases, and if the issue remains unsolved - leave a comment regarding the problem in the thread.


Please sign in to leave a comment.