Warning after initializing Plugin Gradle Template

Answered

Hello,

I downloaded the plugin template to create an IntelliJ IDEA plugin from Github. After initializing and adding plugin description, I ran the plugin just to see if the dependencies were setup properly. When I run, I get following warning:

1) WARN - #c.i.n.i.NotificationGroupManagerImpl - Notification group CodeWithMe is already registered (group=com.intellij.notification.NotificationGroup@1375c3b1). Plugin descriptor: PluginDescriptor(name=Code With Me, id=com.jetbrains.codeWithMe, descriptorPath=plugin.xml, path=~\.gradle\caches\modules-2\files-2.1\com.jetbrains.intellij.idea\ideaIC\2022.2\42c296374014a649785bb84aa6d8dc2d18f2ca0e\ideaIC-2022.2\plugins\cwm-plugin, version=222.3345.118, package=null, isBundled=true)

 

2) WARN - #o.j.k.i.s.r.KotlinCompilerReferenceIndexStorage - kotlin-data-container is not found

 

I am trying to find similar posts but couldn't find any to help me remove these. Please provide some insight on how to tackle this warnings.

 

Thanks you.

2 comments
Comment actions Permalink

These are warnings that come from the SDK you use – not caused by your plugin. You can ignore them.

1

Please sign in to leave a comment.