I can't use Mangeded Jupyter Server.

Thank you in advance.

Now I use professional version of PyCharm as trial.

I'd like to use the setting of "Use Managed Server". Because it's very easy to run jupyter server automatically.

However, 9009 error happens.

What should I do? Ofcourse, jupyter server runs normally when I run it from another console.

3 comments
Comment actions Permalink

Hi, does the issue persist if you copy-paste the exact command from PyCharm to the terminal? The command I'm talking about is the first line in the log.

0
Comment actions Permalink

Thank you for your reply.

Jupyter would not run when I copy-paste the exact command at the terminal, ether.

However, due to set the environment variables, jupyter runs normally in the terminal!

As for Jupyter, the issue remains. How can I set the environment variables at Jupyter?

0
Comment actions Permalink

There is a known issue about environment variables with Jupyter -- https://youtrack.jetbrains.com/issue/DS-2770/A-way-to-configure-environment-variables-for-a-local-Jupyter-server

Please support the request with your vote. Feel free to follow and comment.

As for the workarounds, I can suggest two options:

- Set the env variables in the terminal, then start PyCharm from this terminal session so it inherits the environment.

For more information on how to start IDE from the terminal, please see:
(Change IDEA to PyCharm in the path)
 
- Start Jupyter server from the terminal and connect PyCharm to it remotely.
 
 
0

Please sign in to leave a comment.