How to block VM:number files from being stepped through when debugging JS in PyCharm?

I'm stepping through a Django application with a Vue front-end using the JS debugger in PyCharm. I can exclude scripts (e.g. Vue itself) from being stepped through by adding them to Settings -> Build, Execution, Deployment -> Debugger -> Stepping -> JavaScript when they are fixed files (e.g. backend.js) but some of the files show as vm:number (e.g. vm:54057) and adding either the number or the vm:number to the list referenced above doesn't seem to do anything.

Has anyone else encountered this and if so have you found a way to work around it?

Thanks!

1 comment
Comment actions Permalink

There doesn't seem to be any way to blackbox such scripts (https://youtrack.jetbrains.com/issue/WEB-57355/Do-not-step-in-anonymous-evaled-scripts-when-debugging)

The issue doesn't occur for me if Do not step into library scripts is disabled - could you check if it works for you?

0

Please sign in to leave a comment.