Stop asking to add to git and make it permanent as in forever and never ask me again!

I've been using PhpStorm for three plus years and it never stops asking me to add to git. I never want to add to git, ever. 

I have changed it to never ask so many times I am tired of saying no and changing settings. I have my settings synced but still "do you want to add this file to git?"... No I do not! I never did and I never will! I will handle git outside of the IDE and never use PHPStorm for this so please stop doing this!

How the hell do you stop it asking to add to git and make it permanent like forever and ever and ever and never ask me again because I do not want it to add my new file to git because I told it NO over and over and over again.

8 comments
Comment actions Permalink

To be clear - you mean the model dialog that appears when you create a file and not the Externally added files can be added to Git notification, right?

If so, here's what should disable it for good:

  1. At File | New Projects Settings | Settings for New Projects | Version Control | Confirmation, set both dropdowns to Do not add.
  2. Do the same at File | Settings. You'll have to do that for each project you use.
0
Comment actions Permalink

Eugene Morozov

My issue is that I have set both of these setting multiple times. This is why I am frustrated to have this modal popup.

I am surprised to go into my "New Project Setting" and they both say "Ask" Are these settings synced to my account? This is a new Ubuntu install. the settings appear to not been synced. There must be an issue with sync as I have been saying "Do not ask again" for years now.

1
Comment actions Permalink

On the Project settings "Do not ask" was persevered for the current project, but it still asked me to add files. Why would it do that for an older project with "Do not ask" set?

1
Comment actions Permalink

There must be an issue with sync as I have been saying "Do not ask again" for years now.

Any chance you've been changing it in settings for a project rather than in New Projects Settings?

On the Project settings "Do not ask" was persevered for the current project, but it still asked me to add files

Could you please share a screenshot of the dialog? Perhaps we are talking about different things. Thanks!

0
Comment actions Permalink

I had changed the settings on Friday to "Do not ask" for "Settings for new projects". However I had already set this particular setting last year.

Previous to last year I was unknowingly setting "per Project settings" thinking it was for all projects.

Here are my current setting for "New projects" bearing in mind, I set this to "Do not ask" last week on Friday

I have experienced the "add file to git" pop up pretty much since I started using phpstorm

0
Comment actions Permalink

Today on my work PC it is telling me that "Externally added files can be added to Git" 

And in the "New Project Setting dialog" (after I changed it again last night)

These settings are not syncing. At work I use both Windows 10 and Ubuntu 22.04 and home I use Windows 10

0
Comment actions Permalink

I also see that in Ctrl + Alt + S my Editor tabs have been changed to default of 10.

Sync is not reliable is it. 

0
Comment actions Permalink

Ben Taylor is there a chance that you are usign Settins Sync feature/plugin?
If so, then Git settings are not synced across IDEs
In case of Settings Repository such settings can be shared.
We are working on better solution for this.

0

Please sign in to leave a comment.