PHPstorm freezes

Hello! I have a small php project. But there are some files where the number of lines is about 10,000.
When I start editing it, freezes appear, for example, I try to copy the text and the copy window comes out and freezes for several minutes. Like on the screen.
I tried to turn on the power safe mode, turned off all plugins, inspections, even upgraded to version 2022.2, before that it was 2021.1. But all the same. Nothing helps. Report Upload id: 2022_09_18_24JH54W8pEU3sf6DPGLVjk (files: PS-222.4167.33_Ра, 1.jpg)


Could you please check if copying with Edit | Copy as Plain Text also causes the freeze?
Also, please share the logs (Help | Collect Logs and Diagnostic Data) after it freezes again.


Thanks for the answer. I tried disabling inspection, disabling all plugins. It's not just about copying, try to enter some code quickly, also quickly copy and paste, then enter and edit something again, then phpstorm slows down and the development environment stops and freezes for a while. Also look in the task manager, phpstorm is heavily loading the processor at this time. Upload id: 2022_09_22_hQFHuV93JNPYAwMM92Mfc6 


The computer itself has the following characteristics: Intel I7 12700K (1700 socket, 12th Gen Intel(R) Core(TM) i7-12700K   3.60 GHz), 32gb ram DDR5, 1tb ssd (Samsung 980 PRO M.2 1ТБ), 6tb hdd, MB ASUS PRIME Z690-A (LGA 1700, Intel Z690), windows 11 pro 64bit (21H2, 22000.832), latest updates installed. 

Version PhpStorm 2022.2.2
Build #PS-222.4167.33, built on September 15, 2022
Licensed to signup scooter
You have a perpetual fallback license for this version.
Subscription is active until August 1, 2025.
Runtime version: 17.0.4+7-b469.53 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 11 10.0
GC: G1 Young Generation, G1 Old Generation
Memory: 3024M
Cores: 20

Non-Bundled Plugins:
    intellij-clock (2.0.0)
    com.intellij.plugins.html.instantEditing (222.4167.21)
    sonnenhut.liveedit.patch (1.5)
    me.arcpointgroup.idea.plugin.swephp (0.3)
    BrowseWordAtCaret (3.0.5)


Thanks! I've found your report on the tracker:
Let's keep this conversation on the tracker then. In general, this looks like a valid issue, and if it's still there for 2022.3, we'll open the issue.


Please sign in to leave a comment.