SSH execution uses local paths

When executing via ssh, the execution keeps using local paths. The server I am executing on is running Linux while I write my code on macOS.

An example of the problem is the following output I get when running the code:

Matplotlib created a temporary config/cache directory at /tmp/matplotlib-gyv78qzr because the default path 
(/Users/username/.config/matplotlib) is not a writable directory

Now, what is called "home" on linux is called "Users" on macOS which is how I spotted the mismatch in the first place. With matplotlib this is not a problem as it creates a temporary directory. However, the physics engine Mujoco is not able to handle this mismatch and is looking for its installation in "Users/username" when actually it is installed in "home/username". 

If I activate "Run with Python Console" in the run configuration, the problem does not appear. However, the debugger does not run using the python console when executed but instead uses the normal mode, i.e. the debugger cannot be used in this scenario as the error messages pop up.

For reference, I attached my run configuration, the ssh configuration and the deployment configuration.



If I run:


via the ssh interpreter, I indeed get a path that starts with "Users" instead of "home".





1 comment

The problem was that it carried over local paths which seems to be activated by default (for what reason?).

To deactivate, go to run configuration settings -> click on the icon on the right of the Environment Variables field -> uncheck "include system environment variables"


Please sign in to leave a comment.